Difference between revisions of "NodeCore OpenJDK"

From VeriBlock Wiki
Jump to: navigation, search
(How can I help?)
 
Line 5: Line 5:
 
== Overview ==
 
== Overview ==
  
We are updating the NodeCore suite to run on OpenJDK
+
As of v0.4.6, the NodeCore suite fully supports OpenJDK on CentOS, Ubuntu, Windows, and Mac OS X.  It also fully backward compatible with Oracle Java 8.
 
 
NodeCore was initially required to run on Oracle Java 1.8 during TestNet.
 
  
 
== How can I help? ==
 
== How can I help? ==
  
Help test the latest NodeCore experiment packages and report bugs on github: https://github.com/VeriBlock/nodecore/issues.
+
Please report any issues or bugs on GitHub: https://github.com/VeriBlock/nodecore/issues.
 
 
'''DISCLAIMER: These are beta versions and most-likely will have bugs!'''
 
 
 
LATEST:
 
 
 
* NodeCore --> most recent: https://mirror1.veriblock.org/nodecore-0.4.5-openjdk.zip
 
** old: https://mirror1.veriblock.org/nodecore-0.4.5-dev.4+openjdk.e9944df.zip
 
* PoP Miner --> https://mirror1.veriblock.org/nodecore-pop-0.4.5-dev.4+openjdk.e9944df.zip
 
* NC_CLI --> use existing version: https://github.com/VeriBlock/nodecore-releases/releases/download/v0.4.3/nodecore-cli-0.4.3.zip
 
 
 
Run on OpenJDK and different OS (Windows, Max, Linux).
 
 
 
If you see an error, submit a detailed issue here, including OS and Java version:
 
 
 
https://github.com/VeriBlock/nodecore/issues
 
 
 
Note that this is the newer nodecore repo where [[NodeCore_Source_Code]] is being migrated to, not the nodecore_releases repo.
 

Latest revision as of 14:48, 12 September 2019

See: Main_Page, NodeCore_Source_Code

Overview

As of v0.4.6, the NodeCore suite fully supports OpenJDK on CentOS, Ubuntu, Windows, and Mac OS X. It also fully backward compatible with Oracle Java 8.

How can I help?

Please report any issues or bugs on GitHub: https://github.com/VeriBlock/nodecore/issues.